PANEL DE CONTROL DE API

Soporte TLS

¿POR QUÉ SOLO ADMITIMOS TLS 1.2 Y SUPERIOR?

El Consejo de Seguridad de la PCI establece las reglas sobre qué tecnologías son aceptables para su uso en la transmisión de datos de titulares de tarjetas. Han identificado explícitamente que TLS 1.0 ya no es una forma sólida de cifrado porque es vulnerable a muchos ataques conocidos.

Casi todos los sitios web han dejado de admitir TLS 1.0 y 1.1, esto se hace para ayudar a proteger su información.

¿ESTÁ AFECTADO?

Si no usa nuestras API, es poco probable que se vea afectado a menos que esté usando un navegador o sistema operativo realmente antiguo. Para verificar si su ordenador/navegador es compatible con TLS 1.2 o superior, por favor visite este enlace: https://www.ssllabs.com/ssltest/viewMyClient.html---to find more details about URL

SOPORTE DE BIBLIOTECA API

Si tiene un código que se conecta con la API de ZeroBounce, debe asegurarse de que seguirá funcionando después del 1 de junio de 2018. Cada lenguaje y biblioteca es diferente, a continuación se muestran los lenguajes más populares.

ESTOS LENGUAJES NECESITARÁN CAMBIOS/ACTUALIZACIONES IMPORTANTES PARA FUNCIONAR:

  • Java 6u45 / 7u45
  • .NET antes de 4.5 (no es compatible con TLS 1.2)
  • .NET 4.5 (requiere cambios de configuración para habilitar explícitamente TLS 1.2)
  • OpenSSL 0.9.8
  • La mayoría de los lenguajes dinámicos como Ruby, PHP y Python se basan en la versión OpenSSL del sistema operativo subyacente. Puede comprobarlo ejecutando la versión OpenSSL. 1.0.1 en el mínimo requerido.
  • PHP 5.5.19 y versiones posteriores son compatibles con TLS 1.2

Puede probar su conexión con varias herramientas y documentación que se encuentran en Internet. Por favor, tenga en cuenta que no somos expertos en todos los lenguajes o marcos, por lo que no podemos probar ni corregir su código.

INSTRUCCIONES ESPECÍFICAS DEL LENGUAJE

  • NET 4.6: TLS 1.2 se utiliza automáticamente. No son necesarios cambios.
  • .NET 4.5: SecurityProtocolType debe cambiarse a Tls12 (utilizando SecurityProtocol Setter)
  • .NET 4.0: Se admite TLS 1.2, pero no hay una enumeración denominada SecurityProtocolType. Utilice (SecurityProtocolType)3072.
  • .NET 3 y versiones anteriores: debe actualizarse a 4.5

Soporte para las versiones predeterminadas del sistema TLS incluidas en .NET

SOPORTE DEL NAVEGADOR

La mayoría de los navegadores han sido compatibles con TLS 1.2 durante varios años.

Los siguientes navegadores NO son compatibles con TLS 1.2 y ya no funcionarán.

  • Google Chrome 29
  • Firefox 26
  • Internet Explorer 10
  • Safari 8
  • iOS 4
  • Android 4

Estadísticas de Panel

Necesita información detallada sobre el uso de la API de validación de correo electrónico? La encontrará en su panel de API.

El Panel de control de la API se encuentra en su cuenta fuera del menú de la izquierda. Cada vez que realiza una llamada a la API, registrará los resultados de la validación del correo electrónico. De este modo, puede ver rápidamente una visión general de su uso de créditos y sus resultados. No se guardan correos electrónicos, solo un recuento de los resultados.

Su Panel de API se encuentra en su cuenta, en el menú de la izquierda.

En el Panel de control de la API, como se ha visto anteriormente, tendrá un menú desplegable con los detalles de los correos inválidos, no enviar y los códigos de estado desconocido. Además, podrá graficar por tendencias diarias o mensuales para obtener una mirada másprofunda en susvalidaciones de correo electrónico. Esto le brinda una mejor perspectiva de cómo ZeroBounce ha ayudado a mejorar su lista de correo electrónico.

En el Panel de control de la API tendrá un menú desplegable con los detalles de los correos inválidos

En la imagen de arriba, hice clic en el estado que no quería mostrar, dejando solo la tendencia de los inválidos. Para obtener más detalles sobre los resultados inválidos, cambie el menú en la parte superior a "Inválidos por Sub_Status".

Hice clic en el estado que no quería mostrar, dejando solo la tendencia de los inválidos

Ahora puede ver el desglose de sub_status de los correos electrónicos "Inválidos". Es una herramienta muy poderosa que le permite ver un resumen de uso por día, meses e incluso años, con una representación visual de la salud de los correos electrónicos que está pasando a través de la API.